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Project Title       Job No.         

Discipline Structural File Ref.         

Review Date             Reviewer           

Project Stage             Circulation         

 

       Legend                    
 

       Pass                         
  

       Fail                         X    
 

       Not Applicable         NA  
 

ITEM CONTENT  

1.0 COMPANY STANDARD TEMPLATE  

1.1 General  

1.11 Company template file   

1.2 Model Units  

1.21 Set model units to kN and m  

2.0 MATERIAL DEFINITIONS  

2.1 Concrete [C60] Material Definition  

2.11 Properties → Material Properties → Add → define material with  

• Name = MAT-C60 
• Type of Design → Concrete  

• Standard → BS(RC) 

• DB → C60 say 
• Standard → None 

• Weight Density = 24 kN/m3 

 

2.12 Properties → Creep/Shrinkage → Add → define creep/shrinkage time dependent material with 
• Name = MAT-C60-CREEP 
• Code → CEB-FIP(1990) 

• fck = 60,000 kN/m2 say 
• RH = 80 % 
• h = 0.2 m default representative [note Properties → Change Property → automatic Notional Size of 

Member applies to 1D frame elements; for 2D slabs and walls enter representative h value] 
• Type of cement = Normal or rapid hardening cement (N, R) 
• Age = 3 days 

 

2.13 Properties → Comp. Strength → Add → define comp. strength time dependent material with 

• Name = MAT-C60-STRENGTH 
• Type → Code 
• Code → CEB-FIP(1990) 
• fck+f = 68,000 kN/m2 say 

• Cement type → N, R : 0.25 

 

2.14 Properties → Material Link → link time dependent material with 

• Time Dependent Material Type (Creep/Shrinkage) → MAT-C60-CREEP 
• Time Dependent Material Type (Comp. Strength) → MAT-C60-STRENGTH 
• Select Material to Assign → MAT-C60 → Operation Add /Modify → Close 

 

2.2 Concrete [C50] Material Definition  

2.21 Properties → Material Properties → Add → define material with 
• Name = MAT-C50 

• Type of Design → Concrete 

• Standard → BS(RC) 

• DB → C50 say 

• Standard → None 

• Weight Density = 24 kN/m3 

 

2.22 Properties → Creep/Shrinkage → Add → define creep/shrinkage time dependent material with 

• Name = MAT-C50-CREEP 
• Code → CEB-FIP(1990) 

• fck = 50,000 kN/m2 say 
• RH = 80 % 
• h = 0.2 m default representative [note Properties → Change Property → automatic Notional Size of 

Member applies to 1D frame elements; for 2D slabs and walls enter representative h value] 

 

Abbreviations 
 

TM = Tree Menu 
CSW = Construction Stage Wizard 
 
Note “say” refers to user input based on designed building in question. The figures are marked in red.  
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ITEM CONTENT  

• Type of cement = Normal or rapid hardening cement (N, R) 
• Age = 3 days 

2.23 Properties → Comp. Strength → Add → define comp. strength time dependent material with 

• Name = MAT-C50-STRENGTH 
• Type → Code 
• Code → CEB-FIP(1990) 
• fck+f = 58,000 kN/m2 say 

• Cement type → N, R : 0.25 

 

2.24 Properties → Material Link → link time dependent material with 

• Time Dependent Material Type (Creep/Shrinkage) → MAT-C50-CREEP  
• Time Dependent Material Type (Comp. Strength) → MAT-C50-STRENGTH 
• Select Material to Assign → MAT-C50 → Operation Add /Modify → Close 

 

2.3 Concrete [C40] Material Definition  

2.31 Properties → Material Properties → Add → define material with 
• Name = MAT-C40 
• Type of Design → Concrete  

• Standard → BS(RC) 

• DB → C40 say 

• Standard → None 

• Weight Density = 24 kN/m3 

 

2.32 Properties → Creep/Shrinkage → Add → define creep/shrinkage time dependent material with 

• Name = MAT-C40-CREEP 
• Code → CEB-FIP(1990) 

• fck = 40,000 kN/m2 say 
• RH = 80 % 
• h = 0.2 m default representative [note Properties → Change Property → automatic Notional Size of 

Member applies to 1D frame elements; for 2D slabs and walls enter representative h value] 

• Type of cement = Normal or rapid hardening cement (N, R) 
• Age = 3 days 

 

2.33 Properties → Comp. Strength → Add → define comp. strength time dependent material with 

• Name = MAT-C40-STRENGTH 
• Type → Code 
• Code → CEB-FIP(1990) 

• fck+f = 48,000 kN/m2 say 

• Cement type → N, R : 0.25 

 

2.34 Properties → Material Link → link time dependent material with 

• Time Dependent Material Type (Creep/Shrinkage) → MAT-C40-CREEP 
• Time Dependent Material Type (Comp. Strength) → MAT-C40-STRENGTH  

• Select Material to Assign → MAT-C40 → Operation Add /Modify → Close 

 

2.4 Concrete [C40-PSEUDO] Material Definition  

2.41 Properties → Material Properties → Add → define material with 

• Name = MAT-C40-PSEUDO 
• Type of Design → Concrete  

• Standard → None 

• Modulus of Elasticity → 0 kN/m2 
• Weight Density → 0 kN/m3 

 

2.42 Properties → Creep/Shrinkage → Add → define creep/shrinkage time dependent material with 

• Name = MAT-C40-PSEUDO-CREEP 
• Code → CEB-FIP(1990) 

• fck = 40,000 kN/m2 say 

• RH = 80 % 
• h = 0.2 m default representative [note Properties → Change Property → automatic Notional Size of 

Member applies to 1D frame elements; for 2D slabs and walls enter representative h value] 
• Type of cement = Normal or rapid hardening cement (N, R) 
• Age = 3 days 

 

2.43 Properties → Comp. Strength → Add → define comp. strength time dependent material with 

• Name = MAT-C40-PSEUDO-STRENGTH 
• Type → Code 
• Code → CEB-FIP(1990) 

• fck+f = 48,000 kN/m2 say 

• Cement type → N, R : 0.25 

 

2.44 Properties → Material Link → link time dependent material with  
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• Time Dependent Material Type (Creep/Shrinkage) → MAT-C40-PSEUDO-CREEP 
• Time Dependent Material Type (Comp. Strength) → MAT-C40-PSEUDO-STRENGTH 

• Select Material to Assign → MAT-C40-PSEUDO → Operation Add / Modify → Close 

2.5 Tendon Material Definition  

2.51 Properties → Material Properties → Add → define material with  

• Name = MAT-TENDON 
• Type of Design → Steel 

• Standard → EN05(S) 

• DB → Y1860S7(15.7mm) 

 

3.0 SECTION DEFINITIONS  

3.1 Column Section Definition  

3.11 Properties → Section Properties → Add → DB/User → define section with 

• Name = SECT-COLUMN-XX 
• Type → Solid Rectangle 
• Type → User 
• H = 0.900 m say 
• B = 0.600 m say 
• Offset = Centre-Centre 

 

3.2 Beam Section Definition  

3.21 Properties → Section Properties → Add → DB/User → define section with 

• Name = SECT-BEAM-XX 
• Type → Solid Rectangle 
• Type → User 
• H = 0.750 m say 
• B = 0.250 m say 
• Offset = Centre-Top 

 

3.3 Null Beam Section Definition  

3.31 Properties → Section Properties → Add → DB/User → define section with 

• Name = SECT-NULL-BEAM-WALL  
• Type → Solid Rectangle 
• Type → User 

• H = 0.100 m say 
• B = 0.100 m say 
• Offset = Centre-Top 

 

3.32 Properties → Section Properties → Add → DB/User → define section with 
• Name = SECT-NULL-BEAM-TENDON  
• Type → Solid Rectangle 

• Type → User 
• H = 0.100 m say 
• B = 0.100 m say 
• Offset = Centre-Top 

 

3.4 Wall Thickness Definition  

3.41 Properties → Thickness → Add → Value → define thickness with 
• In-plane & Out-of-plane = 0.200 m say 

 

3.5 Slab Thickness Definition  

3.51 Properties → Thickness → Add → Value → define thickness with 
• In-plane & Out-of-plane = 0.150 m say 

 

3.6 Cracked Section Definition  

3.61 Properties → Scale Factor → Section Stiffness Scale Factor → define cracked beam sections with 

• Boundary Group Name → GROUP-SUPPORT-FOUNDATIONS 

• Ixx = 0.01 
• Iyy = 0.50 
• Izz = 0.50 

Properties → Scale Factor → Plate Stiffness Scale Factor → define cracked slab sections with 

• Boundary Group Name → GROUP-SUPPORT-FOUNDATIONS 
• Mxy = 0.50 
• Mxx = 0.50 
• Myy = 0.50 
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4.0 GEOMETRY MODELLING  

4.1 Geometry Modelling  

4.11 CSC.Orion R18SP5 → ProtaStructure 2016SP12.3 → ProtaStructure 2018SP4.0 
[Note install Autodesk Revit 2018 | ProtaBIM2019 | MidasLinkSetupforRevit2018] 
Autodesk Revit 2018 → File → New Project → Template File: ProtaStructure_Metric_2018.rte → OK → Prota 

BIM → Import from ProtaStructure → select ProtaStructure project to import → Open → Start 
Autodesk Revit 2018 → Add-Ins → External Tools → Send Model to MidasGen with 

• Element Size = Fine 
• Export Target = All 
• Unit → Force → kN | Length → mm 
• Section Mapping → Auto-Search 

MidasGen → New Project → Import → MidasGen MGT File 
Reassign sections and materials of null beams for wall line loads to SECT-NULL-BEAM-WALL and MAT-C40-
PSEUDO 
Reassign sections and materials of null beams for tendon loads to SECT-NULL-BEAM-TENDON and MAT-C40-
PSEUDO 
 
OR 
 
TM → Tables → Structure Tables → Nodes → copy and paste node definitions from a FEM model #1 
TM → Tables → Structure Tables → Elements → copy and paste beam element (beam and column) definitions 
(node IDs, material IDs and property IDs) from a FEM model #1 
TM → Tables → Structure Tables → Elements → copy and paste plate element (slab and wall) definitions (node 
IDs, material IDs and property IDs) from a FEM model #1 
TM → Tables → Structure Tables → Static Loads → Pressure Loads → copy and paste pressure load definitions 
(load magnitude, plate element IDs and load case IDs) from a FEM model #1 

TM → Tables → Structure Tables → Static Loads → Beam Loads → copy and paste beam load definitions (load 
magnitude, beam element IDs and load case IDs) from a FEM model #1 

TM → Tables → Structure Tables → Static Loads → Nodal Loads → copy and paste nodal load definitions (load 

magnitude, node IDs and load case IDs) from a FEM model #1 

 

#1 Note FEM model refers to a (optional) slab and wall meshed analytical ProtaStructure | OASYS.GSA model 

 

4.2 Storey Definition  

4.21 Structure → Control Data → Story → Auto Generate Story Data → define building stories BASE:StXX selecting 
only levels with floor elements with 

• Include Seismic Accidental Eccentricity = 5% of Plan Dimension 
• Include Wind Eccentricity = 15% of Plan Dimension 
• Floor = Consider | Do not consider 

Note that Auto Generation of Story Data should also include Wind and Seismic floor plate dimensions and 
loading eccentricities. In models with intermittent nodes between stories, in a temporary model, delete all 
vertical elements before Auto Generating the Story Data and subsequently adding St00. Storey diaphragms 
should not be considered for base floor St00, any particular floors with offset beams and any particular floors 
with X and/or Y nodal restraints. 
Note that stories are defined for the following purposes: - 

• to apply storey-based lateral loads 
• to define storey-based floor diaphragms 
• to extract storey-based displacement and stress (force) effects 

 

4.3 Section Assignment  

4.31 Right-Click → Select → Window → select corresponding elements 
TM → Works → Properties → Section → drag and drop sections to assign onto elements: - 

• SECT-BEAM-XX 
• SECT-COLUMN-XX 

TM → Works → Properties → Thickness → drag and drop thicknesses to assign onto slab elements 
TM → Works → Properties → Thickness → drag and drop thicknesses to assign onto wall elements 

 

4.4 Material Assignment  

4.41 Right-Click → Select → Window → select corresponding elements by section 
TM → Works → Properties → Material → drag and drop materials to assign onto elements: - 

• MAT-C60 onto SECT-COLUMN-XX 
• MAT-C40 onto SECT-BEAM-XX 

Right-Click → Select → Window → select corresponding elements 
TM → Works → Properties → Material → drag and drop materials to assign onto elements: - 

• MAT-C50 onto wall elements 
• MAT-C40 onto slab elements 

 

4.5 Group Definition and Assignment  

4.51 TM → Group → Right-Click Tendon Group → New → Rename Group to define group: -  
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• GROUP-TENDON-A | GROUP-TENDON-B | GROUP-TENDON-C 

5.0 BOUNDARY CONDITION DEFINITIONS  

5.1 Foundation Rigid Support  

5.11 Right-Click → Select → Window → select column base nodes 
Boundary → Define Supports → define boundary condition with 

• Boundary Group Name → Default [note subsequently GROUP-SUPPORT-FOUNDATIONS in CSW] 

• Options → Add 

• D-ALL → select 
• R-ALL → select 

 

6.0 LOAD CASE AND LOADING DEFINITIONS  

6.1 Dead Load [Self-Weight]  

6.11 Load → Static Loads → Static Load Cases → define load case with 

• Name = LC-SELF-WEIGHT 
• Case → All Load Case 

• Type → Construction Stage Load (CS) 

 

6.12 Load → Static Loads → Self Weight → define load with 

• Load Case Name = LC-SELF-WEIGHT 
• Load Group Name = Default [note subsequently GROUP-LOAD-SELF-WEIGHT in CSW] 
• X = 0 
• Y = 0 
• Z = -1 

 

6.2 Superimposed Dead Load [Finishes]  

6.21 Load → Static Loads → Static Load Cases → define load case with 

• Name = LC-G-AREA 
• Case → All Load Case 
• Type → Construction Stage Load (CS) 

 

6.22 TM → Works → Structures → Stories → select corresponding slab elements by storey BASE:StXX 

Load → Static Loads → Pressure Loads → Assign Pressure Loads → define load with 

• Type = Load Case 
• Load Case Name = LC-G-AREA 
• Load Group Name = Default [note subsequently GROUP-LOAD-G-AREA-StXX in CSW] 
• Options → Add 

• Element Types → Plate/Plane Stress(Face) 
• Selection → Element 
• Pressure Face → Face #1 

• Direction → Global Z 
• Projection → No 

• Loads → Uniform 
• P1 = -1.5 kN/m2 say 

 

6.3 Superimposed Dead Load [Wall]  

6.31 Load → Static Loads → Static Load Cases → define load case with 

• Name = LC-G-LINE 
• Case → All Load Case 
• Type → Construction Stage Load (CS) 

 

6.32 Right-Click → Select → Window → select corresponding beam elements 
Load → Static Loads → Element → define beam line load with 

• Load Case Name = LC-G-LINE 
• Load Group Name = Default [note subsequently GROUP-LOAD-G-LINE-StXX in CSW] 
• Options → Add 
• Load Type → Uniform Loads 

• Direction → Global Z 

• Projection → No 

• Value → Relative 
• x1 = 0 and w = -10 kN/m say 
• x2 = 1 

 

6.33 Right-Click → Select → Window → select corresponding slab elements 
Load → Static Loads → Pressure Loads → Assign Pressure Loads → define slab line load with 

• Type → Load Case 
• Load Case Name = LC-G-LINE 
• Load Group Name = Default [note subsequently GROUP-LOAD-G-LINE-StXX in CSW] 
• Options → Add 
• Element Types → Plate/Plane Stress(Edge) 

• Selection → Element 
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• Pressure Edge → Edge #1 | #2 | #3 | #4 
• Direction → Global Z 

• Projection → No 
• Loads → Uniform 
• P1 = -10 kN/m say 

 
OR 
 
Right-Click → Select → Window → select corresponding null beam elements for wall line loads by section SECT-
NULL-BEAM-WALL 
Load → Static Loads → Element → define beam line load with 

• Load Case Name = LC-G-LINE 
• Load Group Name = Default [note subsequently GROUP-LOAD-G-LINE-StXX in CSW] 
• Options → Add 
• Load Type → Uniform Loads 

• Direction → Global Z 
• Projection → No 
• Value → Relative 

• x1 = 0 and w = -10 kN/m say 
• x2 = 1 

6.4 Tendon Load  

6.41 Load → Static Loads → Static Load Cases → define load case with 
• Name = LC-TENDON 
• Case → All Load Case 

• Type → Construction Stage Load (CS) 

 

6.42 Load → Temp./Prestress → Tendon Property → Add → define tendon property with 

• Tendon Name = TENDON-A | TENDON-B | TENDON-C 
• Tendon Type → Internal(Post-Tension) 
• Material → MAT-TENDON 

• Total Tendon Area = Click <…> to specify tendon area with  
o Strand Diameter → 12.7 mm or 15.2 mm say 
o Number of Strands = 30 say 

• Duct Diameter = 0.1 m say 
• Relaxation Coefficient → CEB-FIP 1990 with  

o rho1000 = 2.5 % say 
• Ultimate Strength = 1.86326e+006 kN/m2 say 
• Yield Strength = 1.56906e+006 kN/m2 say 
• Curvature Friction Factor = 0.30 say 
• Wobble Friction Factor = 0.0033 1/m say 
• Anchorage Slip(Draw in) Begin = 0.006 m say 
• Anchorage Slip(Draw in) End = 0 m say 
• Bond Type → Bonded say 

 

6.43 Load → Temp./Prestress → Tendon Profile → Add → define tendon profile with 

• Tendon Name = CABLE-A | CABLE-B | CABLE-C | CABLE-D | CABLE-E 
• Group → GROUP-TENDON-A | GROUP-TENDON-B | GROUP-TENDON-C 
• Tendon Property → TENDON-A | TENDON-B | TENDON-C 
• Assigned Elements = [select PT beam elements by section SECT-BEAM-XX | select PT slab elements 

(grouped or ungrouped) tendon positions by section SECT-NULL-BEAM-TENDON] 
• Input Type → 2D 

• Curve Type → Spline 

• Transfer Length → User Defined Length 

 

6.44 Load → Temp/Prestress → Tendon Prestress → define tendon prestress load with 

• Load Case Name → LC-TENDON 

• Load Group Name → Default [note subsequently GROUP-LOAD-TENDON-StXX in CSW] 
• Select Tendon for Loading = CABLE-A | CABLE-B | CABLE-C | CABLE-D | CABLE-E 
• Stress Value → select Force → define tendon force with  

o Begin = 75% x no. of strands x strand breaking load kN say 
o End = 0 kN say 
o 1st Jacking → Begin say 

 

6.5 Live Load  

6.51 Load → Static Loads → Static Load Cases → define load case with 
• Name = LC-Q 
• Case → All Load Case 

• Type → Live Load (L) 

 

6.52 TM → Works → Structures → Stories → select corresponding slab elements by storey BASE:StXX  
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Load → Static Loads → Pressure Loads → Assign Pressure Loads → define load with 
• Type = Load Case 
• Load Case Name = LC-Q 
• Load Group Name = Default 
• Options → Add 

• Element Types → Plate/Plane Stress(Face) 

• Selection → Element 
• Pressure Face → Face #1 

• Direction → Global Z 
• Projection → No 

• Loads → Uniform 
• P1 = -3.5 kN/m2 say 

6.6 Notional Horizontal Load  

6.61 Load → Static Loads → Static Load Cases → define load case with 

• Name = LC-NHL-X | LC-NHL-Y 
• Case → All Load Case 
• Type → Imperfection Load (I) 

 

6.62 Load → Static Loads → Nodal Body Force → define load with 

• Load Case Name → LC-NHL-X 

• Node List = [Right-Click → Select → Window → select all nodes] 

• Masses to be Converted → select Nodal Mass | Load to Mass | Structure Mass 

• Nodal Body Force Factor  
o X = 0.015 
o Y = 0 
o Z = 0 

Load → Static Loads → Nodal Body Force → define load with 

• Load Case Name → LC-NHL-Y 

• Node List = [Right-Click → Select → Window → select all nodes] 

• Masses to be Converted → select Nodal Mass | Load to Mass | Structure Mass 

• Nodal Body Force Factor  
o X = 0 
o Y = 0.015 
o Z = 0 

 

6.7 Wind Load  

6.71 Load → Static Loads → Static Load Cases → define load case with 

• Name = LC-WIND-X | LC-WIND-XY | LC-WIND-Y | LC-WIND-YX 
• Case → All Load Case 
• Type → Wind Load on Structure (W) 

 

6.72 Load → Static Loads → Wind Loads → Add → define load with 

• Load Case Name → LC-WIND-X | LC-WIND-XY | LC-WIND-Y | LC-WIND-YX 
• Wind Load Code → BS6399(1997) | Site Category → Town 
• Building Type Factor (Kb) → 1 

• Basic Wind Speed (Vb) = 0 m/s 
• Mean Roof Height (Ho) = 0 m 
• Separation of Building (X) = 0 m 
• Frictional Drag Coef. (Cf) = 0 
• Closest Distance to Sea = 0 km 
• Wind Speed Factors = 1 | 1 | 1 | 1 
• Wind Load Direction Factor (Scale Factor) = X-Dir. = 1 | Y-Dir. = 1 
• Additional Wind Loads → define along-wind and cross-wind loads → WX | WXY | WY | WYX 

 

6.8 Seismic Load  

6.81 Load → Dynamic Loads → RS Functions → Add → define response spectrum function with 

• Function Name = EURO2004 H-DESIGN | EURO2004 V-DESIGN 
• Spectral Data Type → Normalized Accel. 

• Scale Factor = 1 
• Gravity = 9.806m/s2 
• Damping Ratio = 0.05 say 
• Design Spectrum → Eurocode-8(2004) 

• National Annex → Recommended 
• Spectrum Type → Horizontal Design Spectrum | Vertical Design Spectrum 
• Ground Type → C say 

• Spectrum Parameters → Type1 say 
• Ref. Peak Ground Acc. (AgR) = 0.07 g say 
• Importance Factor (I) → 1.0 say 

• Behaviour Factor (q) = 1.5 say 
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• Lower Bound Factor (b) = 0.2 say 
• Max. period = 6 sec say 

Load → Dynamic Loads → RS Functions → Add → define response spectrum function with 

• Function Name = EURO2004 H-ELASTIC | EURO2004 V-ELASTIC 
• Spectral Data Type → Normalized Accel. 

• Scale Factor = 1 
• Gravity = 9.806m/s2 
• Damping Ratio = 0.05 say 
• Design Spectrum → Eurocode-8(2004) 

• National Annex → Recommended 
• Spectrum Type → Horizontal Elastic Spectrum | Vertical Elastic Spectrum 

• Ground Type → C say 
• Spectrum Parameters → Type1 say 
• Ref. Peak Ground Acc. (AgR) = 0.07 g say 
• Importance Factor (I) → 1.0 say 

• Viscous Damping Ratio = 5 % say 
• Max. period = 6 sec say 

6.82 Load → Dynamic Loads → RS Load Cases → Add → define seismic load cases with 

• Load Case = LC-EQ-X-DESIGN | LC-EQ-Y-DESIGN 
• Direction → X-Y 
• Excitation Angle → 0 | 90 

• Scale Factor = 1 
• Period Modification = 1 
• Modal Combination → Modal Combination Type → CQC 

• Spectrum Functions → Function Name → EURO2004 H-DESIGN 
• Interpolation of Spectral Data → Logarithmic 

Load → Dynamic Loads → RS Load Cases → Add → define seismic load cases with 
• Load Case = LC-EQ-Z-DESIGN 
• Direction → Z 

• Scale Factor = 1 
• Period Modification = 1 
• Modal Combination → Modal Combination Type → CQC 

• Spectrum Functions → Function Name → EURO2004 V-DESIGN 
• Interpolation of Spectral Data → Logarithmic 

Load → Dynamic Loads → RS Load Cases → Add → define seismic load cases with 

• Load Case = LC-EQ-X-ELASTIC | LC-EQ-Y-ELASTIC 
• Direction → X-Y 
• Excitation Angle → 0 | 90 
• Scale Factor = 1 
• Period Modification = 1 
• Modal Combination → Modal Combination Type → CQC 

• Spectrum Functions → Function Name → EURO2004 H-ELASTIC 
• Interpolation of Spectral Data → Logarithmic 

Load → Dynamic Loads → RS Load Cases → Add → define seismic load cases with 

• Load Case = LC-EQ-Z-ELASTIC 
• Direction → Z 
• Scale Factor = 1 
• Period Modification = 1 
• Modal Combination → Modal Combination Type → CQC 
• Spectrum Functions → Function Name → EURO2004 V-ELASTIC 

• Interpolation of Spectral Data → Logarithmic 

 

6.83 Analysis → Eigenvalue → define Eigenvalue Analysis Control with 

• Type of Analysis → select Eigen Vectors → Lanczos 

• Eigen Vectors → Number of Frequencies → 30 say 

 

6.84 Structure → Structure Type → define structure type and mass control with 

• Structure Type → 3-D 
• Mass Control Parameter → Lumped Mass | Consistent Mass 
• Mass Control Parameter → select Convert Self-Weight into Masses → select Convert to X, Y, Z 

• Gravity Acceleration = 9.806 m/s2 
• Initial Temperature = 21 [C] 
• Select Align Top of Beam Section with Floor (X-Y Plane) for Panel Zone Effect / Display 

 

6.85 Load → Static Loads → Loads to Masses → define  

• Mass Direction → X, Y, Z 
• Load Type for Converting → Nodal Load | Beam Load | Floor Load | Pressure (Hydrostatic) 
• Gravity = 9.806 m/s2 
• Load Case: LC-G-AREA | LC-G-LINE 
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7.0 CONSTRUCTION STAGE DEFINITIONS  

7.1 Construction Stage Wizard and Group Definition and Assignment  

7.11 Load → Construction Stage → CSW → Automatic Generation → define construction stages with 

• Construction Stage → LoadCase → LC-SELF-WEIGHT | Story Incr. = 1 | Stage Duration = 10 day(s) | 
Member Age = 3 day(s) 

• Superimposed Dead Load 1 → LoadCase → LC-G-AREA | Story Incr. = 1 | Starting Day = 11 day(s) | 
Day Incr. = 10 day(s) 

• Superimposed Dead Load 2 → LoadCase → LC-G-LINE | Story Incr. = 1 | Starting Day = 11 day(s) | 
Day Incr. = 10 day(s) 

• Superimposed Dead Load 3 → LoadCase → LC-TENDON | Story Incr. = 1 | Starting Day = 1 day(s) | 
Day Incr. = 10 day(s) 

Note that tendon loads are applied at the same time as self-weight loads whilst superimposed dead loads are 
assumed to lag one (1) floor cycle. 

 

7.12 TM → Group → Structure Group → Right-Click to rename groups: - 
• #CS01 to GROUP-STOREY-St01 
• #CS02 to GROUP-STOREY-St02 
• #CS03 to GROUP-STOREY-St03 
• #CS04 to GROUP-STOREY-St04 
• #CS[NS] to GROUP-STOREY-St[NS] 

Note NS is the total no. of storeys in the building. 
Note alternatively the manual method of defining Structure Groups is Structure → Structure → Define Structure 
Group → define group with 

• Name = GROUP-STOREY-St 
• Suffix = 01 to 09 | 10 to NS 

Note NS is the total no. of storeys in the building. 
Right-Click → Select → Window → select corresponding elements 
TM → Group → drag and drop group to assign onto elements: - 

• GROUP-STOREY-StXX onto columns, beams, slabs and walls of StXX 

 

7.13 TM → Group → Boundary Group → Right-Click to rename group: - 

• #CS01 to GROUP-SUPPORT-FOUNDATIONS 
 

7.14 TM → Group → Load Group → Right-Click to rename group: - 

• #CS01 to GROUP-LOAD-SELF-WEIGHT 
 

7.15 TM → Group → Load Group → Right-Click to rename group: - 
• #AD1_01 to GROUP-LOAD-G-AREA-St01 
• #AD1_02 to GROUP-LOAD-G-AREA-St02 
• #AD1_03 to GROUP-LOAD-G-AREA-St03 
• #AD1_04 to GROUP-LOAD-G-AREA-St04 
• #AD1_[NS] to GROUP-LOAD-G-AREA-St[NS] 

Note NS is the total no. of storeys in the building. 
TM → Group → Load Group → Right-Click to rename group: - 

• #AD2_01 to GROUP-LOAD-G-LINE-St01 
• #AD2_02 to GROUP-LOAD-G-LINE-St02 
• #AD2_03 to GROUP-LOAD-G-LINE-St03 
• #AD2_04 to GROUP-LOAD-G-LINE-St04 
• #AD2_[NS] to GROUP-LOAD-G-LINE-St[NS] 

Note NS is the total no. of storeys in the building. 

 

7.16 TM → Group → Load Group → Right-Click to rename group: - 
• #AD3_01 to GROUP-LOAD-TENDON-St01 
• #AD3_02 to GROUP-LOAD-TENDON-St02 
• #AD3_03 to GROUP-LOAD-TENDON-St03 
• #AD3_04 to GROUP-LOAD-TENDON-St04 
• #AD3_[NS] to GROUP-LOAD-TENDON-St[NS] 

Note NS is the total no. of storeys in the building. 

 

7.2 Construction Stage(s) #CS-StXX [Construction of Multi-Storey Floors, Post-Tensioning and 
Application of Superimposed Dead Loads] 

 

7.21 Load → Construction Stage → Define C.S → Modify/Show → check construction stage with 

• Name = #CS01 to #CS-St01 
• Duration = 10 day(s) 
• Element → check GROUP-STOREY-St01 → Activation with Age = 10 day(s) 

• Boundary → check GROUP-SUPPORT-FOUNDATIONS → Activation with Deformed Support / Spring 
Position 

• Load → check GROUP-LOAD-SELF-WEIGHT → Activation with Active Day = First 
• Load → check GROUP-LOAD-TENDON-St01 → Activation with Active Day = First 

 

7.22 Load → Construction Stage → Define C.S → Modify/Show → check construction stage with  
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• Name = #CS02 to #CS-St02 
• Duration = 10 day(s) 
• Element → check GROUP-STOREY-St02 → Activation with Age = 10 day(s) 

• Boundary → none 

• Load → check GROUP-LOAD-G-AREA-St01 → Activation with Active Day = First 

• Load → check GROUP-LOAD-G-LINE-St01 → Activation with Active Day = First 

• Load → check GROUP-LOAD-TENDON-St02 → Activation with Active Day = First 

7.23 Load → Construction Stage → Define C.S → Modify/Show → check construction stage with 

• Name = #CS03 to #CS-St03 
• Duration = 10 day(s) 
• Element → check GROUP-STOREY-St03 → Activation with Age = 10 day(s) 

• Boundary → none 
• Load → check GROUP-LOAD-G-AREA-St02 → Activation with Active Day = First 

• Load → check GROUP-LOAD-G-LINE-St02 → Activation with Active Day = First 
• Load → check GROUP-LOAD-TENDON-St03 → Activation with Active Day = First 

 

7.24 Load → Construction Stage → Define C.S → Modify/Show → check construction stage with 

• Name = #CS04 to #CS-St04 
• Duration = 10 day(s) 
• Element → check GROUP-STOREY-St04 → Activation with Age = 10 day(s) 

• Boundary → none 
• Load → check GROUP-LOAD-G-AREA-St03 → Activation with Active Day = First 

• Load → check GROUP-LOAD-G-LINE-St03 → Activation with Active Day = First 
• Load → check GROUP-LOAD-TENDON-St04 → Activation with Active Day = First 

 

7.25 Load → Construction Stage → Define C.S → Modify/Show → check construction stage with 
• Name = #CS[NS] to #CS-St[NS] 
• Duration = 10 day(s) 
• Element → check GROUP-STOREY-St[NS] → Activation with Age = 10 day(s) 

• Boundary → none 

• Load → check GROUP-LOAD-G-AREA-St[NS-1] → Activation with Active Day = First 

• Load → check GROUP-LOAD-G-LINE-St[NS-1] → Activation with Active Day = First 
• Load → check GROUP-LOAD-TENDON-St[NS] → Activation with Active Day = First 

 

7.26 Load → Construction Stage → Define C.S → Modify/Show → check construction stage with 

• Name = #CS_dummy to #CS-EOC 
• Duration = 1 day(s) 
• Element → none 

• Boundary → none 
• Load → check GROUP-LOAD-G-AREA-St[NS] → Activation with Active Day = First 

• Load → check GROUP-LOAD-G-LINE-St[NS] → Activation with Active Day = First 

 

7.3 Construction Stage #CS-FINALE [Long Term]  

7.31 Load → Construction Stage → Define C.S → Add → define construction stage with 

• Name = #CS-FINALE 
• Duration = 10,000 day(s) 
• Element → none 
• Boundary → none 

• Load → none 

 

7.4 Additional Creep Material and Construction Stage Settings  

7.41 Properties → Change Property → select all elements → automatically calculate the notional size of all frame 
members with 

• Element Dependent Material → Notional Size of Member 

• Code → CEB-FIP(1990) 

 

7.42 Analysis → Construction Stage → define construction stage settings with 

• Final Stage → Last Stage 

• Analysis Option → Analysis Type → Linear Analysis → select Accumulative Stage 
• Include Time Dependent Effect 
• Cable-Pretension Force Control → Internal Force 
• Composite Section → select Calculate Output of Each Part 

• Load Cases to be Distinguished from Dead Load for C.S. Output → none 

 

7.43 Load → Construction Stage → Composite Section for C.S. → none  
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8.0 ANALYSIS  

8.1 Perform Analysis  

8.11 Analysis → Perform Analysis  

8.2 Load Combinations   

8.21 Results → Load Combination → define additional ULS and SLS load cases with 

• [ULS] DL+SDL → Type : Add →  
o Dead Load(CS)     :1.4 
o Tendon Secondary(CS)    :1.0 
o Creep(CS)     :1.0 
o Shrinkage(CS)     :1.0 

• [SLS] DL+SDL → Type : Add →  
o Dead Load(CS)     :1.0 
o Tendon Primary(CS)     :1.0 
o Tendon Secondary(CS)     :1.0 
o Creep(CS)      :1.0 
o Shrinkage(CS)      :1.0 

 
• [SLS] NHL:X → Type : Add →  

o LC-NHL-X (ST)     :1.0 
• [SLS] -NHL:X → Type : Add →  

o LC-NHL-X (ST)     :-1.0 
• [SLS] NHL:Y → Type : Add →  

o LC-NHL-Y (ST)     :1.0 
• [SLS] -NHL:Y → Type : Add →  

o LC-NHL-Y (ST)     :-1.0 
• [SLS] NHL:ENV → Type : Envelope →  

o [SLS] NHL:X(CB)      :1.0 
o [SLS] -NHL:X(CB)     :1.0 
o [SLS] NHL:Y(CB)      :1.0 
o [SLS] -NHL:Y(CB)     :1.0 

 
• [SLS] WL1:X+ → Type : Add →  

o LC-WIND-X (ST)     :1.0 
o LC-WIND-XY (ST)     :1.0 

• [SLS] WL2:X- → Type : Add →  

o LC-WIND-X (ST)     :1.0 
o LC-WIND-XY (ST)     :-1.0 

• [SLS] -WL3:X- → Type : Add →  

o LC-WIND-X (ST)     :-1.0 
o LC-WIND-XY (ST)     :-1.0 

• [SLS] -WL4:X+ → Type : Add →  

o LC-WIND-X (ST)     :-1.0 
o LC-WIND-XY (ST)     :1.0 

• [SLS] WL5:Y+ → Type : Add →  

o LC-WIND-Y (ST)     :1.0 
o LC-WIND-YX (ST)     :1.0 

• [SLS] WL6:Y- → Type : Add →  

o LC-WIND-Y (ST)     :1.0 
o LC-WIND-YX (ST)     :-1.0 

• [SLS] -WL7:Y- → Type : Add →  

o LC-WIND-Y (ST)     :-1.0 
o LC-WIND-YX (ST)     :-1.0 

• [SLS] -WL8:Y+ → Type : Add →  

o LC-WIND-Y (ST)     :-1.0 
o LC-WIND-YX (ST)     :1.0 

• [SLS] WL:ENV → Type : Envelope →  

o [SLS] WL1:X+(CB)    :1.0 
o [SLS] WL2:X-(CB)     :1.0 
o [SLS] -WL3:X-(CB)     :1.0 
o [SLS] -WL4:X+(CB)     :1.0  
o [SLS] WL5:Y+(CB)    :1.0 
o [SLS] WL6:Y-(CB)     :1.0 
o [SLS] -WL7:Y-(CB)    :1.0 
o [SLS] -WL8:Y+(CB)    :1.0 

 
• [ULS] EQ1:X+0.3Y+0.3Z → Type : Add → 
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o LC-EQ-X-DESIGN(RS)     :1.0 
o LC-EQ-Y-DESIGN(RS)     :0.3 
o LC-EQ-Z-DESIGN(RS)     :0.3 

• [ULS] EQ2:X-0.3Y+0.3Z → Type : Add → 

o LC-EQ-X-DESIGN(RS)     :1.0 
o LC-EQ-Y-DESIGN(RS)     :-0.3 
o LC-EQ-Z-DESIGN(RS)     :0.3 

• [ULS] EQ3:-X-0.3Y+0.3Z → Type : Add → 

o LC-EQ-X-DESIGN(RS)     :-1.0 
o LC-EQ-Y-DESIGN(RS)     :-0.3 
o LC-EQ-Z-DESIGN(RS)     :0.3 

• [ULS] EQ4:-X+0.3Y+0.3Z → Type : Add → 

o LC-EQ-X-DESIGN(RS)     :-1.0 
o LC-EQ-Y-DESIGN(RS)     :0.3 
o LC-EQ-Z-DESIGN(RS)     :0.3 

• [ULS] EQ5:0.3X+Y+0.3Z → Type : Add →  

o LC-EQ-X-DESIGN(RS)     :0.3 
o LC-EQ-Y-DESIGN(RS)     :1.0 
o LC-EQ-Z-DESIGN(RS)     :0.3 

• [ULS] EQ6:0.3X-Y+0.3Z → Type : Add →  

o LC-EQ-X-DESIGN(RS)     :0.3 
o LC-EQ-Y-DESIGN(RS)     :-1.0 
o LC-EQ-Z-DESIGN(RS)     :0.3 

• [ULS] EQ7:-0.3X-Y+0.3Z → Type : Add →  

o LC-EQ-X-DESIGN(RS)     :-0.3 
o LC-EQ-Y-DESIGN(RS)     :-1.0 
o LC-EQ-Z-DESIGN(RS)     :0.3 

• [ULS] EQ8:-0.3X+Y+0.3Z → Type : Add →  

o LC-EQ-X-DESIGN(RS)     :-0.3 
o LC-EQ-Y-DESIGN(RS)     :1.0 
o LC-EQ-Z-DESIGN(RS)     :0.3 

• [ULS] EQ9:0.3X+0.3Y+Z → Type : Add →  

o LC-EQ-X-DESIGN(RS)     :0.3 
o LC-EQ-Y-DESIGN(RS)     :0.3 
o LC-EQ-Z-DESIGN(RS)     :1.0 

• [ULS] EQ10:0.3X-0.3Y+Z → Type : Add →  

o LC-EQ-X-DESIGN(RS)     :0.3 
o LC-EQ-Y-DESIGN(RS)     :-0.3 
o LC-EQ-Z-DESIGN(RS)     :1.0 

• [ULS] EQ11:-0.3X-0.3Y+Z → Type : Add →  

o LC-EQ-X-DESIGN(RS)     :-0.3 
o LC-EQ-Y-DESIGN(RS)     :-0.3 
o LC-EQ-Z-DESIGN(RS)     :1.0 

• [ULS] EQ12:-0.3X+0.3Y+Z → Type : Add →  

o LC-EQ-X-DESIGN(RS)     :-0.3 
o LC-EQ-Y-DESIGN(RS)     :0.3 
o LC-EQ-Z-DESIGN(RS)     :1.0 

• [ULS] EQ:ENV → Type : Envelope →  
o [ULS] EQ1:X+0.3Y+0.3Z(CB)   :1.0  
o [ULS] EQ2:X-0.3Y+0.3Z(CB)    :1.0 
o [ULS] EQ3:-X-0.3Y+0.3Z(CB)    :1.0 
o [ULS] EQ4:-X+0.3Y+0.3Z(CB)    :1.0 
o [ULS] EQ5:0.3X+Y+0.3Z(CB)    :1.0 
o [ULS] EQ6:0.3X-Y+0.3Z(CB)    :1.0 
o [ULS] EQ7:-0.3X-Y+0.3Z(CB)    :1.0 
o [ULS] EQ8:-0.3X+Y+0.3Z(CB)    :1.0 
o [ULS] EQ9:0.3X+0.3Y+Z(CB)    :1.0 
o [ULS] EQ10:0.3X-0.3Y+Z(CB)    :1.0 
o [ULS] EQ11:-0.3X-0.3Y+Z(CB)    :1.0 
o [ULS] EQ12:-0.3X+0.3Y+Z(CB)    :1.0 

• [SLS] EQ1:X+0.3Y+0.3Z → Type : Add → 

o LC-EQ-X-ELASTIC(RS)     :1.0 
o LC-EQ-Y-ELASTIC(RS)     :0.3 
o LC-EQ-Z-ELASTIC(RS)     :0.3 

• [SLS] EQ2:X-0.3Y+0.3Z → Type : Add → 

o LC-EQ-X-ELASTIC(RS)     :1.0 
o LC-EQ-Y-ELASTIC(RS)     :-0.3 
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o LC-EQ-Z-ELASTIC(RS)     :0.3 
• [SLS] EQ3:-X-0.3Y+0.3Z → Type : Add → 

o LC-EQ-X-ELASTIC(RS)     :-1.0 
o LC-EQ-Y-ELASTIC(RS)     :-0.3 
o LC-EQ-Z-ELASTIC(RS)     :0.3 

• [SLS] EQ4:-X+0.3Y+0.3Z → Type : Add → 

o LC-EQ-X-ELASTIC(RS)     :-1.0 
o LC-EQ-Y-ELASTIC(RS)     :0.3 
o LC-EQ-Z-ELASTIC(RS)     :0.3 

• [SLS] EQ5:0.3X+Y+0.3Z → Type : Add →  

o LC-EQ-X-ELASTIC(RS)     :0.3 
o LC-EQ-Y-ELASTIC(RS)     :1.0 
o LC-EQ-Z-ELASTIC(RS)     :0.3 

• [SLS] EQ6:0.3X-Y+0.3Z → Type : Add →  

o LC-EQ-X-ELASTIC(RS)     :0.3 
o LC-EQ-Y-ELASTIC(RS)     :-1.0 
o LC-EQ-Z-ELASTIC(RS)     :0.3 

• [SLS] EQ7:-0.3X-Y+0.3Z → Type : Add →  

o LC-EQ-X-ELASTIC(RS)     :-0.3 
o LC-EQ-Y-ELASTIC(RS)     :-1.0 
o LC-EQ-Z-ELASTIC(RS)     :0.3 

• [SLS] EQ8:-0.3X+Y+0.3Z → Type : Add →  

o LC-EQ-X-ELASTIC(RS)     :-0.3 
o LC-EQ-Y-ELASTIC(RS)     :1.0 
o LC-EQ-Z-ELASTIC(RS)     :0.3 

• [SLS] EQ9:0.3X+0.3Y+Z → Type : Add →  

o LC-EQ-X-ELASTIC(RS)     :0.3 
o LC-EQ-Y-ELASTIC(RS)     :0.3 
o LC-EQ-Z-ELASTIC(RS)     :1.0 

• [SLS] EQ10:0.3X-0.3Y+Z → Type : Add →  

o LC-EQ-X-ELASTIC(RS)     :0.3 
o LC-EQ-Y-ELASTIC(RS)     :-0.3 
o LC-EQ-Z-ELASTIC(RS)     :1.0 

• [SLS] EQ11:-0.3X-0.3Y+Z → Type : Add →  

o LC-EQ-X-ELASTIC(RS)     :-0.3 
o LC-EQ-Y-ELASTIC(RS)     :-0.3 
o LC-EQ-Z-ELASTIC(RS)     :1.0 

• [SLS] EQ12:-0.3X+0.3Y+Z → Type : Add →  

o LC-EQ-X-ELASTIC(RS)     :-0.3 
o LC-EQ-Y-ELASTIC(RS)     :0.3 
o LC-EQ-Z-ELASTIC(RS)     :1.0 

• [SLS] EQ:ENV → Type : Envelope →  
o [SLS] EQ1:X+0.3Y+0.3Z(CB)   :1.0  
o [SLS] EQ2:X-0.3Y+0.3Z(CB)    :1.0 
o [SLS] EQ3:-X-0.3Y+0.3Z(CB)    :1.0 
o [SLS] EQ4:-X+0.3Y+0.3Z(CB)    :1.0 
o [SLS] EQ5:0.3X+Y+0.3Z(CB)    :1.0 
o [SLS] EQ6:0.3X-Y+0.3Z(CB)    :1.0 
o [SLS] EQ7:-0.3X-Y+0.3Z(CB)    :1.0 
o [SLS] EQ8:-0.3X+Y+0.3Z(CB)    :1.0 
o [SLS] EQ9:0.3X+0.3Y+Z(CB)    :1.0 
o [SLS] EQ10:0.3X-0.3Y+Z(CB)    :1.0 
o [SLS] EQ11:-0.3X-0.3Y+Z(CB)    :1.0 
o [SLS] EQ12:-0.3X+0.3Y+Z(CB)    :1.0 

8.22 Results → Load Combination → define ULS load combinations with 

• [ULS] COMBO1:1.4DL+1.4SDL+1.6LL → Type : Add →  
o [ULS] DL+SDL(CB)    :1.0 
o LC-Q(ST)     :1.6 

 
• [ULS] COMBO2:1.4DL+1.4SDL+1.0NHL → Type : Add →  

o [ULS] DL+SDL(CB)    :1.0 
o [SLS] NHL:ENV(CB)    :1.0 

 
• [ULS] COMBO3:1.0DL+1.0SDL+1.0NHL → Type : Add →  

o [SLS] DL+SDL(CB)    :1.0 
o [SLS] NHL:ENV(CB)    :1.0 
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• [ULS] COMBO4:1.2DL+1.2SDL+1.2LL+1.0NHL → Type : Add →  
o [SLS] DL+SDL(CB)    :1.2 
o LC-Q(ST)     :1.2 
o [SLS] NHL:ENV(CB)    :1.0 

 

• [ULS] COMBO5:1.4DL+1.4SDL+1.4WL → Type : Add →  
o [ULS] DL+SDL(CB)    :1.0 
o [SLS] WL:ENV(CB)    :1.4 

 
• [ULS] COMBO6:1.0DL+1.0SDL+1.4WL → Type : Add →  

o [SLS] DL+SDL(CB)    :1.0 
o [SLS] WL:ENV(CB)    :1.4 

 
• [ULS] COMBO7:1.2DL+1.2SDL+1.2LL+1.2WL → Type : Add →  

o [SLS] DL+SDL(CB)    :1.2 
o LC-Q(ST)     :1.2 
o [SLS] WL:ENV(CB)    :1.2 

 
• [ULS] COMBO8:1.0DL+1.0SDL+2iLL+1.0EQ → Type : Add →  

o [SLS] DL+SDL(CB)    :1.0 
o LC-Q(ST)     :2i 

o [ULS] EQ:ENV(CB)    :1.0 

8.23 Results → Load Combination → define SLS load combinations with 

• [SLS] COMBO1:1.0DL+1.0SDL+1.0LL+1.0NHL → Type : Add →  
o [SLS] DL+SDL(CB)    :1.0 
o LC-Q(ST)     :1.0 
o [SLS] NHL:ENV(CB)    :1.0 

 
• [SLS] COMBO2:1.0DL+1.0SDL+1.0LL+1.0WL → Type : Add →  

o [SLS] DL+SDL(CB)    :1.0 
o LC-Q(ST)     :1.0 
o [SLS] WL:ENV(CB)    :1.0 

 
• [SLS] COMBO3:1.0DL+1.0SDL+2iLL+1.0EQ → Type : Add →  

o [SLS] DL+SDL(CB)    :1.0 
o LC-Q(ST)     :2i 

o [SLS] EQ:ENV(CB)    :1.0 

 

8.24 Results → Load Combination → define load combinations envelope with 

• [ULS] ALL:ENV → Type : Envelope →  
o [ULS] COMBO1:1.4DL+1.4SDL+1.6LL(CB)  :1.0 
o [ULS] COMBO2:1.4DL+1.4SDL+1.0NHL(CB)  :1.0 
o [ULS] COMBO3:1.0DL+1.0SDL+1.0NHL(CB)  :1.0 
o [ULS] COMBO4:1.2DL+1.2SDL+1.2LL+1.0NHL(CB) :1.0 
o [ULS] COMBO5:1.4DL+1.4SDL+1.4WL(CB)  :1.0 
o [ULS] COMBO6:1.0DL+1.0SDL+1.4WL(CB)  :1.0 
o [ULS] COMBO7:1.2DL+1.2SDL+1.2LL+1.2WL(CB) :1.0 
o [ULS] COMBO8:1.0DL+1.0SDL+2iLL+1.0EQ(CB) :1.0 

 
• [SLS] ALL:ENV → Type : Envelope →  

o [SLS] COMBO1:1.0DL+1.0SDL+1.0LL+1.0NHL(CB) :1.0 
o [SLS] COMBO2:1.0DL+1.0SDL+1.0LL+1.0WL(CB) :1.0 
o [SLS] COMBO3:1.0DL+1.0SDL+2iLL+1.0EQ(CB) :1.0 
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9.0 DESIGN  

9.1 Overall Effects Check [Volume by Element Type]  

9.11 Right-Click → Select → Window → select corresponding slab elements by material MAT-C40 [TM → Works 
→ Properties → Material] or thickness [TM → Works → Properties → Thickness] 
Query → Element Weight Table → manually sum the division of Total Weight (kN) / Unit Weight (kN/m3) to 

obtain the total element volume (m3) 
 
Right-Click → Select → Window → select corresponding beam elements by material MAT-C40 [TM → Works 
→ Properties → Material] or section SECT-BEAM-XX [TM → Works → Properties → Section] 
Query → Element Weight Table → manually sum the division of Total Weight (kN) / Unit Weight (kN/m3) to 
obtain the total element volume (m3) 
 
Right-Click → Select → Window → select corresponding wall elements by material MAT-C50 [TM → Works 
→ Properties → Material] or thickness [TM → Works → Properties → Thickness] and column elements by 
material MAT-C60 [TM → Works → Properties → Material] or section SECT-COLUMN-XX [TM → Works → 
Properties → Section] 
 
Query → Element Weight Table → manually sum the division of Total Weight (kN) / Unit Weight (kN/m3) to 
obtain the total element volume (m3) 

 

9.2 Overall Effects Check [Volume by Element Type by Storey]  

9.21 Query → Story Weight Table → manually sum the division of Total Element Weight (kN) / Unit Weight (kN/m3) 
to obtain the total element volume (m3) 

 

9.3 Overall Effects Check [Total DL+SDL | LL | WL]  

9.31 Results → Results Table → Reaction → check total DL+SDL with 

• Node or Element → All 
• Loadcase/Combination → select [SLS] DL+SDL(CB) 

Results → Results Table → Reaction → check total LL with 

• Node or Element → All 

• Loadcase/Combination → select LC-Q(ST) 

 

9.32 Results → Results Table → Story → Story Axial Force Sum → check axial force accumulation by storey with 

• Loadcase/Combination → select [SLS] DL+SDL(CB) | LC-Q(ST) 
 

9.33 Results → Results Table → Story → Story Shear Force Ratio → check building lateral stability storey (and base) 
shear with 

• Loadcase/Combination → select LC-WIND-X(ST) | LC-WIND-XY(ST) | LC-WIND-Y(ST) | LC-WIND-

YX(ST) 
Results → Results Table → Story → Overturning Moment → check building lateral stability storey (and base) 
moment with 

• Loadcase/Combination → select LC-WIND-X(ST) | LC-WIND-XY(ST) | LC-WIND-Y(ST) | LC-WIND-

YX(ST) 

 

9.4 Overall Effects Check [Reactions]  

9.41 Results → Reaction → Reaction Forces/Moments → check reactions with 

• Load Cases / Combinations → CS#1 Min/Max → CSmax: Summation | Post CS → CBall: [SLS] ALL:ENV 

• Components → FXYZ | MXYZ 
• Type of Display → select Values | Legend 

#1 Note that CS refers to construction stage defined by Load → Construction Stage → Stage Display 

 

9.5 Overall Effects Check [Displacements]  

9.51 Results → Deformations → Displacement Contour → check vertical displacements with 

• Load Cases / Combinations → CS#1 Min/Max → CSmin: Summation | Post CS → CBmin: [SLS] ALL:ENV 
• Components → DZ 
• Type of Display → select Contour | Deform | Legend 

#1 Note that CS refers to construction stage defined by Load → Construction Stage → Stage Display 

 

9.52 Results → Results Table → Story → Story Displacement → check lateral displacements with 

• Loadcase/Combination → select LC-WIND-X(ST) | LC-WIND-XY(ST) | LC-WIND-Y(ST) | LC-WIND-

YX(ST) 
Results → Results Table → Story → Story Drift → check lateral drift with 

• Loadcase/Combination → select LC-WIND-X(ST) | LC-WIND-XY(ST) | LC-WIND-Y(ST) | LC-WIND-

YX(ST) 
• Story Drift Parameters → Cd = 1 | Ie = 1 | Scale Factor = 1 | Allowable Ratio = 0.002 

 

9.6 TLS Stress [PT] Check  

9.61 Element TLS Stress [PT] Check 

 
Slab CS CS-StXX → CS: Summation #1 

Beam CS CS-StXX → CS: Summation #2 

#1 Results → Stresses → Plane-Stress/Plate Stresses → check combined stresses with 
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• Load Cases / Combinations → CS CS-StXX → CS: Summation 
• Stress Options → Top | Bottom 

• Components → Sig-xx | Sig-yy | Sig-max 
• Type of Display → select Contour | Legend 

#2 Results → Stresses → Beam Stresses Diagram → check axial precompression and combined stresses with 

• Load Cases / Combinations → CS CS-StXX → CS: Summation 
• Components → Part → Total 

• Components → Sax | Combined [1|2|3|4] 
• Fill Type → Solid 

• Type of Display → select Contour | Legend 

9.7 ULS Design, ULS Stress [RC] and SLS Stress [PT] Checks  

9.71 Element ULS Design ULS Stress [RC] Check SLS Stress [PT] Check  

 

Slab [ULS] ALL:ENV #1A [ULS] ALL:ENV #1B [SLS] ALL:ENV #1C  

Beam [ULS] ALL:ENV #2A [ULS] ALL:ENV #2B [SLS] ALL:ENV #2C  

Wall [ULS] ALL:ENV #3A [ULS] ALL:ENV #3B N / A  

Column [ULS] ALL:ENV #4A [ULS] ALL:ENV #4B N / A  

 #1A Results → Stresses → Plate Forces/Moments → check vertical bending moments with 

• Load Cases / Combinations → CBall: [ULS] ALL:ENV 
• Plate Force Options → UCS 

• Plate Force Options → Avg. Nodal 
• Components → Mxx | Myy | Mmax [Sagging] | Mmin [Hogging] 

• Type of Display → select Contour | Legend 
#1B Results → Stresses → Plane-Stress/Plate Stresses → check bending stresses with 

• Load Cases / Combinations → CBall: [ULS] ALL:ENV 

• Stress Options → UCS 
• Stress Options → Avg. Nodal 

• Stress Options → Top | Bottom 
• Components → Sig-xx | Sig-yy | Sig-max [Sagging] | Sig-min [Hogging] 
• Type of Display → select Contour | Legend 

#1C Results → Stresses → Plane-Stress/Plate Stresses → check combined stresses with 

• Load Cases / Combinations → CBall: [SLS] ALL:ENV 

• Stress Options → UCS 
• Stress Options → Avg. Nodal 
• Stress Options → Top | Bottom 

• Components → Sig-xx | Sig-yy | Sig-max [Sagging] | Sig-min [Hogging] 
• Type of Display → select Contour | Legend 

#2A Results → Forces → Beam Diagrams → check vertical bending moments and vertical shear forces with 

• Load Cases / Combinations → CBall: [ULS] ALL:ENV 
• Components → Part → Total 

• Components → My | Fz 
• Type of Display → Solid Fill 

• Type of Display → select Contour | Legend 
#2B Results → Stresses → Beam Stresses Diagram → check combined stresses with 

• Load Cases / Combinations → CBall: [ULS] ALL:ENV  
• Components → Part → Total 
• Components → Combined [1|2|3|4] 

• Fill Type → Solid 
• Type of Display → select Contour | Legend 

#2C Results → Stresses → Beam Stresses Diagram → check axial precompression and combined stresses with 

• Load Cases / Combinations → CBall: [SLS] ALL:ENV 
• Components → Part → Total 

• Components → Sax | Combined [1|2|3|4] 
• Fill Type → Solid 

• Type of Display → select Contour | Legend 
#3A Results → Stresses → Plate Forces/Moments → check vertical axial forces with 

• Load Cases / Combinations → CBall: [ULS] ALL:ENV 

• Plate Force Options → Local 
• Plate Force Options → Avg. Nodal 

• Components → Fyy 
• Type of Display → select Contour | Legend 

#3B Results → Stresses → Plane-Stress/Plate Stresses → check axial stresses with 

• Load Cases / Combinations → CBall: [ULS] ALL:ENV 
• Stress Options → UCS 

• Stress Options → Avg. Nodal 
• Stress Options → Top | Bottom 
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• Components → Sig-zz 
• Type of Display → select Contour | Legend 

#4A Results → Forces → Beam Diagrams → check axial forces with 

• Load Cases / Combinations → CBall: [ULS] ALL:ENV 
• Components → Part → Total 

• Components → Fx 
• Type of Display → Solid Fill 

• Type of Display → select Contour | Legend 
#4B Results → Stresses → Beam Stresses Diagram → check axial stresses with 

• Load Cases / Combinations → CBall: [ULS] ALL:ENV  

• Components → Part → Total 
• Components → Sax 

• Fill Type → Solid 
• Type of Display → select Contour | Legend 

9.8 ULS and SLS Design  

9.81 Results → Load Combination → General → select all loading combinations and Copy into Concrete Design 
Results → Load Combination → Concrete Design → define ULS and SLS combinations [ULS] COMBO1 | [ULS] 
COMBO2 | [ULS] COMBO3 | [ULS] COMBO4 | [ULS] COMBO5 | [ULS] COMBO6 | [ULS] COMBO7 | [ULS] 
COMBO8 | [SLS] COMBO1 | [SLS] COMBO2 | [SLS] COMBO3 as Strength/Stress type whilst all other cases as 
Inactive type 

 

9.82 Design → General Design Parameter → define general design parameters with 

• Definition of Frame → define design parameters with 

o X-Direction of Frame → Braced | Non-sway 
o Y-Direction of Frame → Braced | Non-sway 
o Design Type → 3-D 
o Select Auto-Calculate Effective Length Factors  

• Live Load Reduction Factor → define live load reduction factors 
• Member Assignment → check member-element automatic assignments 

 

9.83 Design → RC Design → define RC design parameters with 

• Design Code → BS8110-97 | Eurocode2:04 [National Annex: Recommended] 

• Partial Safety Factors for Strength of Materials | Partial Safety Factors for Material Properties → Update 

By Code 
• Modify Concrete Material → define concrete and reinforcement design material with 

o Concrete Material Selection → Code → None 
o Concrete Material Selection → Name = MAT-C25 | MAT-C30 | MAT-C35 | MAT-C40 | MAT-

C45 | MAT-C50 | MAT-C55 | MAT-C60 | MAT-C65 | MAT-C70 | MAT-C75 | MAT-C80 
o Concrete Material Selection → Specified Compressive Strength (fc|fck) → 25000 | 30000 | 

35000 | 40000 | 45000 | 50000 | 55000 | 60000 | 65000 | 70000 | 75000 | 80000 kN/m2 
o Rebar Selection → Grade of Main Rebar → S460 
o Rebar Selection → Grade of Sub-Rebar → S460 

• Limiting Maximum Rebar Ratio → define maximum reinforcement % with 
o Shear Wall Design (w) = 0.04 

o Column Design (w) = 0.05 

o Brace Design (w) = 0.04 

• Design Criteria for Rebars → define available rebar sizes 

 

9.84 Design → RC Design → Concrete Code Design → Beam Design → check RC-Beam [Beams Without Offset Slabs] 
Design Results with 

• Select Connect Model View 
• Graphic | Detail 
• Update Rebar 

Note that floor load distribution onto beams with meshed floors will be lesser than floor load distribution onto 
beams without meshed floors. Furthermore, beams with offset slabs will exhibit axial tension at mid-span 
sagging positions and axial compression at support hogging positions (and hence shifting the tensile rebar 
requirement into the slab at these positions). 

 

9.85 Design → RC Design → Concrete Code Design → Brace Design → check RC-Brace [Beams With Offset Slabs] 
Design Results with 

• Select Connect Model View 
• Graphic | Detail 
• Update Rebar 

Note that floor load distribution onto beams with meshed floors will be lesser than floor load distribution onto 
beams without meshed floors. Furthermore, beams with offset slabs will exhibit axial tension at mid-span 
sagging positions and axial compression at support hogging positions (and hence shifting the tensile rebar 
requirement into the slab at these positions). 

 

9.86 Design → RC Design → Concrete Code Design → Column Design → check RC-Column Design Results with 

• Select Connect Model View 
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• Graphic | Detail 
• Update Rebar 

9.87 Design → Meshed Design → define meshed design parameters with 

• Serviceability Load Combination Type → define type of SLS load combination 
• Design Criteria for Rebars → define available rebar sizes  

 

9.88 Design → Meshed Design → check Slab Flexural Design with 

• Load Cases/Combinations → ALL COMBINATION 

• Select Flexural Design → Avg. Nodal | Top | Bottom | Dir. 1 | Dir. 2 
• Type of Display → select Values | Legend 
• Rebar | Asreq | req | x/d | Resistance Ratio 

 

9.89 Design → Meshed Design → check Slab Serviceability Checking  

9.810 Design → Meshed Design → Perform Cracked Section Analysis  

 


